Intermittent 500 Errors on Explorer API and Web3Modal API

Incident Report for Reown

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 21:36 UTC

Investigating

Since August 27, we have observed intermittent spikes in 500 errors affecting api.web3modal.org and explorer-api.walletconnect.org. The underlying issue is related to our database, which is experiencing sudden surges in client connections. Our engineering team is actively investigating and continuing root cause analysis to mitigate the impact.

Users may experience intermittent failures when interacting with the Explorer API and Web3Modal API during these periods. We will provide updates as we learn more.
Posted Sep 05, 2025 - 08:32 UTC
This incident affected: Explorer API.